Wednesday, January 28, 2015

Problem Linking Text in Pages Document In Yosemite - A Solution

[This is for folks who use Mac's Pages rather than Word.  In Mac's Yosemite operating system.]

Here's the problem:  I follow the steps and put in a link but it reverts back to the default link.

I got so frustrated that I made an appointment with an Apple tech guy to call me and after screen sharing with my computer, he agreed it was a glitch, but we came up with a workaround.

STEP 1: write what you want to link.  I wrote the name of this blog:

What Do I Know?

STEP 2 is to highlight it.  You can see I did that in the screenshot to the left.

STEP 3:  Click on the Insert icon (3rd from the left on my computer) then at the bottom is Add Link.  This window (below) should pop up right under the words you highlighted.  In this case, What Do I Know?   So far so good.

Notice that the link says  That's the default and where the trouble comes in soon.

STEP 4:  Highlight the and replace it with the url you want to link to.  I added whatdoino-steve.blogspot

STEP 5:  The next obvious step is to click "Go to Page."  But this is where the problem lies.  Instead of taking me to my blog, it reverted back to the apple link.  I got to the page below.

Now this turns out to be a cool page showing different kinds of art that people had figured out how to make on various apple devices.  I even did a  blog post about that link.  But that's not where I wanted to send people.

After much frustration I was talking to an Apple tech who took me through the steps and did what I did and, much to his surprise, ended up where I ended up.  He toyed around with it and finally came up with a work-around.

STEP 5 (the one that works for me):  After you type in your URL,

  • retype the words you want to be highlighted in the box.  I know, not very efficient, but do it.  And there's one more step.  There shouldn't be, but there is.

STEP 6:  Click outside the little Add Link window.  Somewhere on the page so the window disappears.  If I just click on Go to Page, without first clicking outside the box, it reverts back to the link.

STEP 7:  Put the cursor onto the words you just added the link to - in my case What Do I Know? - and click. Here's the window I got:

BINGO!  it's got the right link. No more  It has my URL.   Hit "Go to Page" and it should take you where you want to go.

It shouldn't be like this and the tech I talked to was writing it up and sending it in.  If we're lucky, this post will become moot.  But in the mean time, this is how you can do it.

Some other thoughts.

1.  This isn't a problem if the words you are linking are the actual URL that you want people to go to.  That works right away.

2.  There's one other little glitch that can hang you up.  When you highlight the words you want to link, from left to right, you may accidentally pick up a little symbol.  It looks like the INSERT symbol we started this all with.  I think it just shows the end of the line (or return).  If you get that into your highlight, then when you hit the insert icon above to start all this, the Add Link option won't be active.  You can see in the picture on the right.

If you look closely at the words I highlighted (What Do I Know?),  you'll see a little blue symbol after the question mark.  And you'll see that in the dropdown window above it, Add Link is not active.  (It's light grey, not  black.)

If you highlight from right to left, you don't get this little icon.  You need to highlight the words without the little icon so it looks like the first screenshot above (Steps 1, 2, 3)

That's it.  I hope this helps people overcome this design flaw.

No comments:

Post a Comment

Comments will be reviewed, not for content (except ads), but for style. Comments with personal insults, rambling tirades, and significant repetition will be deleted. Ads disguised as comments, unless closely related to the post and of value to readers (my call) will be deleted. Click here to learn to put links in your comment.